The identity check fails..

To use the identity check service you need a phone that has NFC. When it comes to Apple you need an iPhone no older than IOS version 13. Unfortunately, iPads cannot be used. Huawei HarmonyOS units are not supported in terms of Android.